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note:

QUICKSTART OVERVIEW (VIDEO LINK)
The purpose of this Quick-Start is to provide you with a simple introduction to PADS Professional. 
Through a series of short exercises, you will learn how to make a simple PCB design using PADS 
Professional. 

Although PADS Professional supports various PCB design flows, this guide focuses on a simplified 
PCB design process where the following topics are introduced.

Before proceeding, please make sure you’ve downloaded, installed and activated 
PADS Professional evaluation software version 2.4 or newer.

 
INSTALLATION & LICENSING (VIDEO LINK)
After placing a request to evaluate PADS Professional, you should've received an email with 
links to

•	 The PADS Professional online installer

and

•	 Ther Software evaluation license

If you did not receive this email, please contact your local authorized Mentor 
Graphics Distributor via https://www.pads.com/buy.

1.	 Double click the online installer to begin the software installation.

You will need to remain connected to the internet until the installation completes. 
Installation time will vary depending on the speed of your internet connection.

2.	 Click "Next".

3.	 Review and accept the license agreement if you agree.

4.	 Click “Next” to accept the recommended installation location.

5.	 When the installation completes, click "Done".

You should now see the PADS Professional Schematic and PADS Professional Layout icons on 
your desktop.

6.	 Download the license file named PADSPro.dat from the link provided to you via email, 
and save this file in  C:\PADS_Professional_QuickStart\.

7.	 Close all windows and proceed to Lesson 1.

OPENING AND 
POPULATING A NEW 

PROJECT

OPENING 
AND POPULATING 
A NEW PROJECT

FORWARD 
ANNOTATING

PCB PHYSICAL 
LAYOUT

ROUTING 
THE PCB

GENERATING 
MANUFACTURING 

FILES

tip:

https://youtu.be/Pmca2UczT3I
https://youtu.be/ATHG1QHzWBA
https://www.pads.com/buy
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LESSON-1: OPENING AND POPULATING A NEW PROJECT (VIDEO LINK)
Opening a new project:

1) From the Windows Start          menu, navigate to the PADS Professional Evaluation 
VX.2.4. folder and click on PADS Designer VX 2.4.

2) Once PADS Designer opens, Go to: File ► Open ► Project.

3) Navigate to C:\PADS_Professional_QuickStart\Lesson 1 - Starting and Populating a New 
Project\, select the file named "LED_Flasher.PRJ" and click Open.

Workspace configuration (Panel size, position, display state, and workspace options) 
can all be customized and shared as templates between different projects or team 
members using PADS Professional.

tip:

https://youtu.be/mnXbdPztsLI
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Populating a new project
1) Add a new sheet to your project by going to: File ► New ► Sheet.

2) The Properties panel will automatically display. Left-click inside each highlighted cell 
and overwrite system generated values as shown below.

3) Left-click to focus on the Navigator panel.

4) Within the Navigator panel, Right-click the file named “3” and click “Rename” from the 
menu.

5) Type “Design” and press Enter key.

6) This concludes Lesson 1: You’ve successfully added a new Schematic sheet to your 
design and customized its Title Block.

7) Go to: File ► Close Project, keep PADS Designer open, then proceed to Lesson 2. 

PADS Professional automatically saves your work.tip:
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LESSON-2: PLACING AND WIRING PARTS (VIDEO LINK)
Searching for and placing parts on your schematic sheet.

1) If not already open, launch PADS Designer and Go to: File ► Open ► Project

2) Navigate to C:\PADS_Professional_QuickStart\Lesson 2 – Placing and Wiring parts\, 
select the file named LED_Flasher.PRJ and click Open.

This project is prepopulated with an incomplete schematic page, which you will 
complete as part of Lesson 2.

3) Within the Navigator panel, Double-click the Design sheet to view its contents.

Within the schematic workspace, scroll middle mouse button forward to zoom in, 
backwards to zoom out. This will improve the visibility of objects on your schematics.

4) Within the Search panel search box, type: "NE555" and press Enter to see the NE555DR 
component as shown below (you may need to click once on the search result to see 
the part’s symbol and footprint). 
 
Upon first opening PADS Designer, you may see the Output panel on top of the Search 
panel. Simply click once on the Search panel tab to bring it into focus.

tip:

note:

note:

https://youtu.be/7AIJAW8p1UU


7www.pads.com October 2018

PADS Professional Evaluation Quick Start GuidePADS ®

PROFESSIONAL

5) Drag and drop the NE555 part from the search area onto the Design sheet (try to 
position your symbols as shown in images to facilitate the wiring process).

Press & hold the middle mouse button while moving your mouse to pan the schematic 
workspace.

6) From the My Parts panel, scroll to locate the Special Component named Source_VCC.1.

7) Drag and drop Source_VCC.1 onto the Design sheet.

8) Repeat Step 7 to add a second Source_VCC.1 component to your schematic (Or hold 
down the CTRL key while dragging the same symbol).

note:
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Wiring your schematic
Net wire colors can be assigned from the Setup ► Settings ► Display ► Objects 
menu. The Color by Net option should then be activated from View ► Color by Nets, 
in order to see the assigned Net Colors.

1) Follow the steps in the image below to wire your Power components (The two VCC 
symbols) to the NE555.

2) Click the Net icon            on the top toolbar area (or Press lowercase n key) to activate 
the wiring tool.

3) After your mouse cursor turns into a crosshair, Left-click and hold on Pin 6 (THRES) of the 
NE555 symbol.

4) Then, move your mouse cursor 2 grid steps to the left and press the Spacebar.

5) While still holding down the left mouse button, move your mouse cursor down 4 grid 
spaces and press the Spacebar again.

6) Finally, move your mouse cursor onto the bottom pin of R8 and release you left mouse 
button.

7) Press the Escape key to cancel the command.

8) You should end up with a wire similar to the one shown below.

tip:
tip:
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Hover your mouse over the Net icon         for 5 seconds to see a short animated 
tutorial.

Catching and fixing potential wiring mistakes
9) Go to: Tools ► Verify.

10) In the Verify window, click the “OK” button.

11) The DRC panel will appear, displaying a list of potential electrical issue.

12) Click on the last error message in the DRC panel to see the unconnected pin in your 
schematic workspace.

While working on your design, you can customize the type of conditions that should 
be monitored and how they should be reported in PADS Designer by adjusting options 
shown in the Verify panel (accessible via Tools ► Verify).

13) Fix these errors by repeating Steps 2-6 of this section, to finish wiring the rest of the 
design as shown.

tip:

tip:
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14) Go to: Tools ► Verify, and Click “Ok”.

15) Notice the errors are gone.

16) Right click on the DRC panel and click “Close”.

You can also place No Connect special components on pins that are purposefully 
left unconnected without changing your design verification rules.tip:
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Placing Net Labels
1) Right click the wire connecting Pin 3 of the NE555 and Pin 11 of the OpAmp, then click 

Properties.

2) Within the Properties panel, change the value of Name to CLK_OUT and press Enter.

3) Notice that there is now a label on this wire. Using this method allows you to easily 
name connections in your design.

4) Click any empty space in your schematic workspace to clear all filters. 

Constraint Manager
Using the constrain manager, you can predefine design rules that will get forward annotated 
to the PCB layout workspace.

1) Click Tools ► Constraint Manager.

2) Within the Constraint Manager’s Navigator panel, select Net Classes ► PWR.
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3) Expand Master, then PWR, and set the Trace Width (th) ► Expansion values to “20”.

At any time, you can toggle between English and Metric units within the Schematic 
Editor properties accessible from: Setup ► Settings ► Schematic Editor.

4) Check the box to not show warning again in the same session, then click OK.

5) Close the Constrain Manager window.

6) Right-click and close the Output panel.

7) Go to: File ► Close Project.

tip:
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LESSON-3: FORWARD ANNOTATE, CREATE A PCB FILE AND DRAW 
YOUR BOARD SHAPE (VIDEO LINK)
During forward annotation, each component in the logical PADS Professional Designer 
workspace is mapped to a physical footprint in the PADS Professional Layout workspace. This 
includes packaging, assigning reference designators and creating an associated PCB file in 
one operation.

Forward Annotate to PCB
1) If not already open, launch PADS Designer and Go to: File ► Open ► Project.

2) Navigate to C:\PADS_Professional_QuickStart\Lesson 3 – Forward Annotation\, select 
the file named LED_Flasher.PRJ and click Open.

3) Within PADS Designer, go to: Tools ► PADS Professional Layout.

4) Set the Template drop down menu to “4 Layer QuickStart_Template” as shown, then 
click “OK”.

The following steps only need to be performed once. PADS Professional Layout 
interface will automatically open and load your base PCB file.

5) Click “Yes” to create the design directory when prompted.

6) Click “Ok” to import the layout template.

7) Click “Ok” to dismiss the message about Back annotation being disabled.

note:

https://youtu.be/8RRZNVcfPn4
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8) Check the box to not show the prompt to forward annotate again, then click “Yes”.

9) PADS Professional Layout interface should have automatically opened, loaded an 
empty PCB, and displayed the Project Integration as shown.

The PCB file name is automatically set to the PADS Designer project name.

10) Within the Project Integration window, click the top amber button to forward 
annotate.

You may see a series of notifications about tasks being processed. They will 
automatically disappear when finished. You may also see a note that Forward 
Annotate completed with warnings. Simply close the output panel.

tip: tip:

note:
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11) Click “Ok” to dismiss the warning message.

12) The amber lights should now be Green, indicating that your schematic and PCB data 
have been synchronized.

13) Click the “Close” button to dismiss the Project Integration window.

14) You now have 2 windows open: The PADS Designer interface displaying your 
schematic, and the PADS Professional Layout interface displaying the contents of your 
PCB.

Feel free to move these 2 windows to different monitors if you have more than 1 
monitor. At this stage, components have been imported into your PCB workspace 
and are ready to be placed on the board. If not visible, enable the Component 
Explorer through the Place ► Component Explorer command.

15) Close the PADS Designer interface 
but leave the PADS Professional Layout interface open.

Define PCB board shape from 3D Step model
Although it is possible to manually draw a complex 2D board shape within PADS Professional 
Layout, in some case it can be quicker to define a 2D board shape based on a 3D model.

1) Within the PADS Professional Layout interface, click the bookmark icon to hide the left 
panel group and expand the visible workspace area.

tip:
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2) Switch to 3D view by going to: Window ► Add 3D view.

3) Within the 3D view, import the Step model by clicking 3D ► Import Mechanical Model

4) Navigate to C:\PADS_Professional_QuickStart\Resources\Step models, select Board 
outline.step and click “Import”.

5) Go to: 3D ►Create Board.

6) Left-click once on the imported Step model.

The top face outline will turn pink on mouse-over, to indicate which face you are 
about to select

7) Position your cursor as show. Left click once when the pink outer circle appears. This will 
define the board origin.

8) Within the Map Hole Features window: Check the box next to “Route Border”, then set 
New Clearance to 20 and click “OK”.

tip:
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9) Right-click the Step body and click “Delete”

10) Click “Yes” to dismiss the prompt. Notice your new board outline.

11) Click once on the view tab named 1:LED_Flasher to view the board outline in 2D View.

12) Press CTRL + B key combination to fit your board outline to the PCB layout space.

13) Go to: File ► Save, then Close the PADS Professional Layout interface.

14) Proceed to the next exercise.
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LESSON-4: PCB PHYSICAL LAYOUT (VIDEO LINK)
Placing footprints from schematics
In this lesson, you will open the schematic and PCB workspaces side by to aid in footprint 
placement. Some footprints have already been grouped and placed on the board for you.

 
Although not required, guiding footprint placement from the schematic workspace 
can speed up the board layout in projects with higher component counts.

1) Launch PADS Professional Layout, then Go to: File ► Open.

2) Navigate to C:\PADS_Professional_QuickStart\Lesson 4 - PCB Physical Layout\PCB\, 
select the file named LED_Flasher.PCB. Click Open.

3) Your workspace has been pre-configured to allow easy placement of parts from the 
Design schematic page.

 
Displaying the schematic view within your layout space does NOT consume a 
schematic license. This method allows users to place parts on their board in an 
organized manner. The following settings are already enabled for you. Windows ► 
Add Schematic View. Within the Component Explorer panel the following options 
are enabled.

 
Parts can also be placed as groups or sequentially by first selecting them from the 
Component Explorer Panel.

If steps 4-6 don’t work for you, toggle the Component Explorer visibility by clicking 
its bookmark icon      twice.

4) Within the Schematic window, use the middle mouse button to zoom into the 
component J1.

5) Left click J1 once such that it is selected (no need to hold down the mouse).

6) Move your mouse cursor over to the PCB layout space and notice how the associated 
footprint to J1 is appended to the cursor and ready to be placed.

7) Press the F3 key to rotate J1’s footprint, position, and left click to place the footprint as 
shown.

tip:

note:

note:

https://youtu.be/-Ke2Zswos-k
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Placing Footprint in 2D/3D Side by side
1) Close the Schematic window.

2) Go to: Windows ► Add 3D view.

3) Go to: Windows ► Tile Vertically.

4) Within the Component Explorer panel, click “Place By Schematic” and “Show list”.

5) Within the Component Explorer list, drag R9 onto the board in 3D View.
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You can view your board in 3D and 2D side by side simultaneously. This can facilitate 
alignment and placement of more complex 3D geometry, especially if placing multi-
body STEP assemblies. STEP model color information will be imported if defined from 
within your MCAD program. Zooming IN/OUT or Panning will move both 2D/3D views. 

6) Within the Component Explorer, drag the “LEDS” group onto the 3D view. 

7) Within the 2D view, right-click the group object’s perimeter and click Place Parts 
Sequentially.

8) Press "F3" to rotate LEDs before placing. Make sure the notch (visible in 3D) is facing the 
top left corner.

Part grouping can be defined from the schematic workspace to simplify part 
placement during layout. You can also select a part and use arrow keys to precisely 
position its footprint.

tip:

tip:
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9) Continue to rotate and place remaining LEDs, as shown below. 
 
Parts that are not yet placed are written in bold text in the Component Explorer.

You may notice some LEDs turning yellow during placement. Live DRC is activated 
and currently set to prevent you from placing parts in positions that violate 
any relevant placement DRC rule. Components with violations will turn yellow. 
 
10) Go to: File ► Close, and click “Yes” when prompted to save.

tip:

note:
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LESSON-5: ROUTING THE PCB (VIDEO LINK)
Adding Fanouts

1) Within PADS Professional Layout, Go to: File ► Open.

2) Navigate to C:\PADS_Professional_QuickStart\Lesson 5 – Routing the PCB\PCB\, select 
the file named LED_Flasher.PCB, and click Open.

3) In the bottom left corner of your screen, click on the “Net Explorer” tab to activate the 
“Net Explorer” panel.

If the Net Explorer tab is not available Go to: Route ► Net Explorer. Then drag and 
drop the Net Explorer panel onto the Component Explorer to tabulate them.

4) Within the Net Explorer panel, select the PWR Net Class and notice that all objects 
assigned the DGND and VCC nets are highlighted on your board.

5) Go to: Route ► Fanout Patterns, ensure the settings are as shown, then click “Fanout 
Selected”.

6) Click “OK” to dismiss the Fanout report, then click close to exit the Fanout Patterns 
window.

You can group your components by creating the appropriate class type. Then select 
the class and run the Fanout command.

tip:

tip:

https://youtu.be/qgPhq4mvgIk
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Single route
Next, let’s route the connection between Pad 8 of component U1 and Pad 1 of R1.

1) Left click once in the empty black space to clear any selection filter.

2) Zoom into U1.

3) Go to: Route ► Add Routes ► Plow (or Press CTRL+Q) to launch single trace routing.

4) Left click once on Pad 8 of U1, move your cursor down, then click on pad 1 of R1 to 
complete the trace.

5) Press the Escape key twice to terminate the route command.

6) Left click once in the empty black space to clear the filter. 
 
When the route command is active, right-click to access a drop down menu to 
change trace width, routing layer, routing modes, and more. Interactive route tuning 
tools are available from the route menu.

 
Sketch Route
Sketch Route allows you to select a set of nets, draw a sketch path, then let the routing engine 
route the selected nets based on the user defined path.

1) In the bottom left panel area, click the Net Explorer tab.

2) Within Net Explorer, under user groups click the LEDS group to select all LED nets 
(Alternatively, draw a selection rectangle across the LED1-6 ratsnests directly in the PCB 
workspace).

tip:
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3) Click Draw Sketch on the bottom toolbar area (Or press F8 key). Then left click once to 
start drawing the sketch path and once again to stop drawing.

4) Click Sketch Route (Or press F9 key).

5) Allow the route engine to route the traces.

6)	 Save your work.

Defining Internal Plane layers and nets
1) Go to: Planes ► Plane Assignments. 

2) Within the Plane Assignments window, under the Layer Usage column for Layer 2, click 
on the keyword Signal and select Plane.
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3) Click the dotted box next to “Layer 2” table entry, then assign it the DGND net as shown 
below.

4) Check the radio button to automatically add Pullbacks, then set the Plane Data State 
to Dynamic.

5) Repeat steps 2-4 to define Layer 3 as a Plane layer assigned to the VCC net.
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6) Click “OK” to apply your changes and dismiss the Plane Assignment window.

7) Go to: View ►Fit Board (Or Press CTRL + B).

8) You should have results similar to the image show below.

Add Layer Stackup Table
1) Go to: Place ► Layer Stackup. 

2) Click OK.

3) Left click to place the Layer Stackup table as shown below.

 



27www.pads.com October 2018

PADS Professional Evaluation Quick Start GuidePADS ®

PROFESSIONAL

View Board in 3D
1) Click the 2:3D View document tab to see a 3D rendering of your board.

While in 3D mode, you can also place parts including multi-body mechanical 
assemblies (such as product enclosures and mounting brackets). Live DRC rules can 
be customized to enforce desired placement behavior.

2) Go to: File ► Close, Click “Yes” to save your changes.

tip:
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LESSON-6: CREATING FABRICATION AND ASSEMBLY FILES (VIDEO LINK)
Board fabricators will typically require a minimum set of design files in order to build your 
board. In this exercise, we focus on adding dimensions to the board and generating a set of 
fabrication and assembly files.

Adding Dimensions
1) Within PADS Professional Layout, Go to: File ► Open.

2) Navigate to C:\PADS_Professional_QuickStart\ Lesson 6 - Creating Fabrication and 
Assembly Files\PCB\, select the file named LED_Flasher.PCB, and click Open.

3) Go to: Draw ► Dimension ► Stacked.

4) Left click once on the top left corner of the board, then nearest edge to the right.

5) Move your cursor up to a desired height and click once again to place the dimension.

6) While the command is still active, click the furthest top right edge of the board and 
move your cursor up to place a second stacked dimension.

7) Press the Escape key twice to cancel the command.

8) Repeat steps 3-7 to dimension the board’s height.

https://youtu.be/BRvmHQZkgC8
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Exporting STEP 3D output
You can export 3D STEP outputs of your board. This file can then be imported into MCAD 
software.

1) Go to: 3D ► Export.

2) Set Type to STEP.

3) Under Metal Element Options, enable the options shown to allow those objects to 
be included in the STEP 3D export (Particularly copper traces, component pads and 
silkscreen information).
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4) Click “Save” to export the 3D Step file to the Output directory of your project.

5) When the indicator stating “Export succeeded” appears, your STEP files have been 
successfully generated.

6) Click “Close”.

Exporting 3D PDF output
To generate a PDF document that includes a self-contained 3D model of your design.

1) Go to: 3D ► Export.

2) Set Type to 3D PDF.

3) Click “Save” to generate the 3D PDF file in your project’s Output directory. Close the 
Export window.

The Output directory in your case is located in C:\PADS_Professional_QuickStart\
Lesson 6 - Creating Fabrication and Assembly Files\PCB\Output. Open the file 
named LED_Flasher.PDF to see the 3D PDF. Within the PDF document, you may need 
to allow execution of 3D content to allow execution of 3D content.

tip:
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Configuring Batch output file generation
Instead of individually generating output files, most file types can be batch generated by 
PADS Professional.

 
In PADS Professional, simply setup your output configuration for each output type 
(example go to: Output ► Gerber or Bill of Materials and setup then save your 
desired options. You can later batch generate all configurations by going to Output 
► Manufacturing Output, and click Generate.

 
1) Go to: Output ► Manufacturing Output.

2) Within the Manufacturing Output window, click the ODB++ setup icon.

3) Within the ODB++ Output window, set the ODB++ Setup file drop down to LED_Flasher_
ODBSetup. 

4) This will load pre-configured ODB++ settings such as layer mapping and overlay 
configuration. You can save time by sharing these files with other users or make them 
part of a project template.

tip:
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5) Click “OK”, then “Generate”

6) Click “NO” to save current settings if prompted. 

You can also go to: Output ► ODB++, then click Generate. This method will 
automatically preview the ODB++ files for you to review before sending to the 
fabrication house.

 
7) The system will begin generating the appropriate files and store them in your project 
output directory.

tip:
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